Mithi solutions support TLS 1.2 as per PCI security standards council mandate

Articles I'm a Customer Ideolve News & Events Skyconnect Vaultastic

As part of our effort to provide you with the most secure data store on the cloud and the highest level of security while consuming our services, our teams are focused on continually enhancing the security of our platform.

We’ve engineered our cloud solutions to comply with the PCI Security Standards Council mandate that requires the deprecation of TLS versions 1.0, recommends the deprecation of TLS 1.1 and requires Internet facing services to use TLS 1.2 for encrypting the transmission channels on all protocols.

TLS is an acronym for “Transport Layer Security,” which is the protocol that secures the channel between two devices (server to server or server to end point) on the Internet so that no outsider can modify or “listen” to the digital transmission.

The latest PCI compliance standards require that any site accepting credit card payments uses TLS 1.2 after June 30, 2018. This mandate has come about, owing to known vulnerabilities in the earlier versions of SSL and TLS.

How does this impact you?

Your use of our services (SkyConnect, Vaultastic, Ideolve) are more secure now, with the transmission channel of all services/protocols protected with TLS 1.2.

The upgrade to TLS 1.2 by Mithi, secures your use of all email, archival and collaboration services including but not limited to SMTP, POP, IMAP, HTTP, XMPP and CalDAV.

Refer to the table below to note the changes/upgrades you may need to make in your end point software tools and OS:

Browsers supported by Baya earlier

Browsers supported after TLS 1.2

Minimum end point OS version supported after TLS 1.2

Chrome 30+ Chrome 33+ Windows (7+), OS X (10.9+), Android (4.1+), iOS (9.0+), Linux
Firefox 22+ Firefox 34+ Windows (7+), OS X (10.9+), Android (4.1+), iOS (9.0+), Linux
Safari 5.1.7+ Safari 7+ OS X (10.9+), iOS (7+)
Opera 12.14 + Opera 20+ Windows (7+), OS X (10.9+), Linux Android (4.0+)
Internet Explorer 9 Internet Explorer 9 Windows 7 – Enable explicitly,
Internet Explorer 10 Internet Explorer 10 Windows 8 – Enable explicitly,
Internet Explorer 11 Internet Explorer 11 Windows 7 +
Microsoft Edge Microsoft Edge Windows 10+

Providing a secure experience enables our customers to feel confident about transacting on our platforms. We understand the importance of security in providing an excellent customer experience.

For any further information about this upgrade, and how it concerns your use of our services, please write in to our helpdesk.


Leave a Reply

Your email address will not be published. Required fields are marked *

*